Setup wizard

This is a Stub article. Help the eZ Publish community by expanding it!

Common problems

Invalid package

You get the error "Invalid package" on the site selection page. Your webserver seems not to be able to connect to the remote repository. You can either try to

  • check if the PHP option allow_url_fopen is enabled, if it's disabled than enable it
  • configure eZ publish to connect to the internet through a proxy server (eZ publish 3.9 or higher)
  • upload the package(s) manually

Related forum topics:

Uploaded file is not an eZ publish package

If you get the error " Uploaded file is not an eZ publish package" on the site selection page then check if the zlib php extension is enabled. Zlib is required to compress and decompress eZ publish packages.

The setup wizard checks if the zlib PHP extension is enabled, but it's an optional component while it should be a required one. This has been reported as issue #8754.

Related forum topics:

External resources